Results 1 to 3 of 3

Thread: Forum upgrading to vBulletin 4.2.2

  1. #1
    Join Date
    Aug 2012
    Location
    Erie, PA
    Posts
    690

    Forum upgrading to vBulletin 4.2.2

    Today we are upgrading our vBulletin forum to version 4.2.2.

    For anyone who would like to know, here is a change log:
    Code:
    vBulletin 4.2.2 is a maintenance release primarily focused on php 5.4 compatibility issues, as well as a few other important fixes for Facebook, PayPal & MAPI updates for Mobile 1.5
    
    The release contains:
    
    * Many fixes for php 5.4 compatibility.
    * MAPI updates for Mobile 1.5
    * Facebook updates due to changes by Facebook
    * PayPal updates due to changes by PayPal.
    * Update to recognise IE11 User Agent
    * Fix Import/export of Navigation Manager (Open new page flag)
    * A couple of security updates in the installer & Forum Runner.
    * Added the Panjo online community marketplace plug-in.
    * A number of other major bugs held over from 4.2.1
    
    vBulletin 4.2.2 contains a total of 109 bug fixes, improvement requests, and feature requests.
    
    VBIV-14509 When original thread is used as a comment thread, it is deleted with the article.
    VBIV-15362 member_activity_start & member_activity_complete do not exist in hooks location dropdown
    VBIV-15408 Product Export - Navigation - Does not export/import 'Open in New Page' flag
    VBIV-15428 Typos in phrases
    VBIV-15443 Small typo in index.php
    VBIV-15615 Publish to Facebook no longer working
    VBIV-15646 Use preg_replace_callback() instead of preg_replace() modifier /e
    VBIV-15680 Indefinite loop on moving posts
    VBIV-15684 There is a newer version of vBulletin available to download - no longer links correctly
    VBIV-15687 IE9 Meta Tag to VB 4.2.1 and 4.2.2. headinclude template - fails with Forum Runner enabled
    VBIV-15694 Facebook July 10 Breaking Changes
    VBIV-15711 echo 1; echo 2 in /private.php
    VBIV-15716 register_addmember does not return success confirmation
    VBIV-15719 blog.post_newblog doesn't include globalcategorybits
    VBIV-15724 "newthread_newthread" does not include max tags info in the response
    VBIV-15725 *"blog_list"* does not include *"postbit_type": "postbit_ignore"* for blog posts by users in Ignore List
    VBIV-15731 Missing space in template bbcode_code
    VBIV-15734 "profile_editprofile" is missing "title" and description" in "profilefield" bits
    VBIV-15747 Paypal IPN / PDT Required Change by Oct 13
    VBIV-15749 Internet Explorer 11 new User Agent
    VBIV-15751 "member" does not include birthday profilefield in response
    VBIV-15753 api_forumlist should not return HTML entities
    VBIV-15759 Call to "register" does not return custom user fields
    VBIV-15777 PHP strict errors not displayed if debug mode is not enabled
    VBIV-15780 PHP5.4: Function set_magic_quotes_runtime() is deprecated
    VBIV-15782 Possible Exploit - can create admin account via install.php and/or upgrade.php
    VBIV-15783 Warning: Non-static method vB_Mail::fetchLibrary() should not be called statically in ....\includes\functions.php on line 1407
    VBIV-15787 CMS Pages : Strict, illegal string offest & other errors
    VBIV-15790 Warning: Non-static method vB_HumanVerify::fetch_library() should not be called statically
    VBIV-15791 Warning: Only variables should be passed by reference in newthread.php
    VBIV-15792 Clicking on tag links results in Warning: Declaration of vB_DataManager_Tag & Declaration of vB_DataManager_category errors
    VBIV-15793 Manually 'Add New User' results in Warning: Declaration of vB_DataManager_PM::set_condition
    VBIV-15795 php 5.4 compliance errors on cms pages
    VBIV-15798 PHP 5.4 compliance errors with social groups
    VBIV-15799 Illegal string offset when importing product XML's (PHP 5.4 compliance)
    VBIV-15800 PHP 5.4 compliance of blog comments
    VBIV-15801 PHP 5.4 compliance of pm quick reply
    VBIV-15802 PHP 5.4 compliance when uploading signature/profile picture
    VBIV-15803 PHP 5.4 compliance when using moderation.php
    VBIV-15805 PHP 5.4 compliance when searching for new articles
    VBIV-15806 PHP 5.4 compliance when adding custom blog page
    VBIV-15809 php 5.5 error on new install
    VBIV-15810 Illegal string offsets in admincp/attachment.php
    VBIV-15811 PHP 5.4 compliance of CMS admin panel
    VBIV-15815 give lots of <br />
    VBIV-15819 Strict standard issues with the Calendar widget in the CMS
    VBIV-15820 CMS strict standard and illegal string offset issues
    VBIV-15821 Update ACP check on install.php
    VBIV-15822 Strict standard with customized profiles
    VBIV-15823 Strict standard error on ForumRunner
    VBIV-15824 Can't view a thread on vB4 / PHP 5.4
    VBIV-15825 Strict Standards in cms articles with comments
    VBIV-15826 Strict standard on edit forum permissions
    VBIV-15828 PHP 5.4, CLI Installer Errors
    VBIV-15829 Strict standard in calendar permissions
    VBIV-15830 Posted CMS comments are not displayed (regression)
    VBIV-15831 Strict standard on API data returns
    VBIV-15833 Warning: Non-static method when changing CMS Section Display Orders.
    VBIV-15835 Strict standards in CMS comments
    VBIV-15839 XSS issue
    VBIV-15841 CMS gives several warnings on VB 4.2.2 with PHP 5.2- Warning: Declaration of vBCms_Item_Widget::getLoadQuery()
    VBIV-15842 BBCode Parser gives several warning on VB 4.2.2 - Warning: Declaration of vB_BbCodeParser_Video_PreParse::handle_bbcode_img()
    VBIV-15844 preg_replace deprecate error in upgrade script
    VBIV-15846 Sending a reply causes Warning: is_a(): Deprecated warning in PHP 5.2 with vBulletin 4.2.2
    VBIV-15848 Strict Standards: Only variables should be passed by reference in ./forumrunner/include/pms.php on line 650
    VBIV-13574 PHP 5.4 check
    VBIV-15779 Move MAPI v8 changes to MAPI v7, and remove v8 completely
    VBIV-15784 Panjo Integration
    VBIV-15794 Credits update for 4.2.2
    VBIV-14784 Incompatibility with PHP 5.4: Functions Removed
    VBIV-14794 Creating JPG-Thumbnails fail with PHP 5.4
    VBIV-15149 Upgrade system throws error: cannon modify header information
    VBIV-15233 PHP 5.4.3 ERROR: Strict standards: Static function vB_Route::getURL() should not be abstract
    VBIV-15307 PHP Warning from postbit
    VBIV-15322 Non-static method vB_QueueMail::fetch_instance() should not be called statically
    VBIV-15496 Cannot edit forum posts when some symbols are used
    VBIV-15563 PHP 5.4.10 and vBulletin 4.2
    VBIV-15577 [PHP 5.4] Warning: Illegal string offset 'title' /includes/adminfunctions_template.php on line 1936
    VBIV-15609 Non-static method vB_Shutdown::instance() should not be called statically
    VBIV-15610 Declaration of vB_Database_Alter_MySQL::drop_index() should be compatible with vB_Database_Alter::drop_index()
    VBIV-15611 Declaration of vB_Database_Alter_MySQL::add_index() should be compatible with vB_Database_Alter::add_index()
    VBIV-15612 Declaration of vB_Database_Alter_MySQL::add_field() should be compatible with vB_Database_Alter::add_field()
    VBIV-15613 Declaration of vB_Database_Alter_MySQL::drop_field() should be compatible with vB_Database_Alter::drop_field()
    VBIV-15614 Declaration of vB_Database_Alter_MySQL::query() should be compatible with vB_Database_Alter::query()
    VBIV-15616 PHP Strict Standards: Non-static method vB_Bitfield_Builder::init() and vB_Bitfield_Builder::build() should not be called statically
    VBIV-15617 PHP Strict Standards vB_Bitfield_Builder class
    VBIV-15618 PHP 5.4 Strict Standards preventing install
    VBIV-15642 [PHP 5.4] Warning: Illegal string offset 'name' in [path]/includes/functions.php on line 6988
    VBIV-15657 PHP 5.4 Strict Standards vB_DataManager_GroupMessage methods signature
    VBIV-15658 PHP 5.4 Strict Standards vB_ProfileBlock methods signatures
    VBIV-15659 PHP 5.4 Strict Standards vB_SGSearchGenerator:: prepare_search_text() method should be static
    VBIV-15660 PHP 5.4 Strict Standards vB_SignatureParser:: parse should be compatible with vB_BbCodeParser:: parse
    VBIV-15661 PHP 5.4 Strict Standards Declaration of vB_DataManager_ThreadPost::verify_pagetext() should be compatible with vB_DataManager::verify_pagetext()
    VBIV-15662 PHP 5.4 Strict Standards Declaration of vB_DataManager_Thread_FirstPost::save() should be compatible with vB_DataManager::save()
    VBIV-15663 PHP 5.4 Fix deprecated & new usage
    VBIV-15664 PHP 5.4 Strict Standards Declaration of vB_DataManager_Moderator::set() should be compatible with vB_DataManager::set()
    VBIV-15665 PHP 5.4 Strict Standards vB_DataManager_VisitorMessage methods signatures
    VBIV-15666 PHP 5.4 Strict Standards vB_DataManager_PictureComment methods signatures
    VBIV-15760 Strict standards in CMS
    VBIV-15761 Strict standards in Blogs
    VBIV-15762 Strict standards in User Profiles
    VBIV-15763 Strict standards in User Control Panel
    VBIV-15764 Strict standards in New Blog Post
    VBIV-15765 Strict standards in CMS after new article submission
    VBIV-15766 Strict standards in New Reply Thread
    VBIV-15767 Strict standards in New Advanced Search form
    VBIV-15768 Strict standards in signature editor when if a signature is displayed in the editor
    VBIV-15669 PHP 5.4 Plugins fail - add compatability option
    Please be patient, we will be back up shortly. I will edit this thread when we are done.
    Thanks!

    ~Wes

    EDIT:
    Upgrading was done. We are back up! Thank you for your patience!

  2. #2
    Join Date
    Aug 2012
    Location
    Houston
    Posts
    769
    I appreciate your work, Wesley.

  3. #3
    Join Date
    Aug 2012
    Location
    Lantana, FL
    Posts
    828
    ok

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
◮ Top